Can’t extend/continue existing line and gpx

Continuing the discussion from Can't extend/continue existing line:

Good day, I am having this problem as well. Working on Mac OS Majove, using Firefox. The line stops after a certain amount of clicks. Then, when I want to continue, the points do not connect. It is making a ‘new item’. I am wondering: is one continuous line necessary for the gpx information? Please advice on this. Thank you, LANijmegen


Can you explain or make a video possibly? I’m also on macOS but it’s working fine.

So you are creating a new line or extending an already existing one? I just created a line with a lot of points in Firefox and all was well.

Is it possible you are clicking too close to the last point which it considers a “close line” event? Because if you click on the last point it closes the line.

I have tried to click on another place than the end of the line. Seemed to be the solution. I worked in Ilustrator and in that software clicking the last point is the way to extend a line.
But it is still not working. What gets in the way is the Mac OS contextual menu. This appears when I control click on my keyboard, as well using my pen and Wacom tablet. I tried to disable the contextual menu but the Mac system does not allow that. Or, I still do not know how to do that. I read on the internet that some websites can disable the contextual menu. But for now there is no solution. Do you have the contextual menu enabled on your Mac? If so, how did you do that. Thank you and greetings, LANijmegen

I mean of course, were you able to DISable the contextual menu.

Hi, the contextual menu in macOS is Control + Left click. Here you need to use the Command key, not Control.


Thank you for your quick reply. You are absolutely right about Control and Command key. Sorry about that. But, the Command key is still giving me a ‘new item’. Greetings, LANijmegen.

Did you go to Edit mode? You need to push this button first, to get into edit mode.


Sorry if this is not clear, the icon might need to be changed.

Yes, now it is working. Thank you so much!

I’m happy I could help.