Trouble with one GPX file

I wonder if anyone can help me.

The following file, which I created on MapHub

Works fine for me on all devices, but one person who follows my walking site is having problems with the download.

He wrote:

“I couldn’t get the GPX file to download as the link didn’t work. It just generates an error message: about:invalid#zSoyz. I have just tried again (using a MacBook Pro 2021 running MacOs Monterey v12.5, browsing with Safari v15.6) with the same results. I then tried using Google Chrome v 105.0.5195.125 but this time got the error code about:blank#blocked. I have no problems downloading GPX files for the other walks, just walk 199!”

Here is the walk he is referring to. The MapHub GPX file is in the text below the static map.

The link works for me and my wife both on mobile and online. It opens fine for me in the OS app, Komoot, Routes, GPXViewer and Relive, so I am puzzled why it works for me and not for this one user.

Any ideas gratefully explored.


Dave (Brewer)
Editor, Hertfordshire Walker

Hi David,

I’ve just tested and I can confirm that everything is working correctly on MapHub’s side for that particular URL. As you’ve experienced it works for both of us as well.

What I’m suspecting is that particular user has some kind of security software or firewall installed on their computer, which is blocking this URL. Turning off the security software would solve this issue.

An other workaround would be to use a mobile phone or tablet, they should also work.

Hi Zsolt, thanks so much for looking into it. Appreciated. David