Multiple versions when people open my MapHub GPX files

I run a website called Hertfordshire Walker that has 190 free walks in the Hertfordshire countryside. Each walk contains a GPX file created on MapHub. However I am finding a couple of issues.

  1. If people download the MapHub GPX file from my site (it’s under the top static map image on each walk), they get two versions. How do I avoid this? As far as I can see I have created one version only.

Here is the latest walk as an example. See screenshot below of what happens when I try to open the latest walk in Komoot. I contacted Komoot and they said it’s because the GPX contains multiple versions.

  1. The GPX files for the walks often won’t open in the OS app. I get the error message “sorry we are unable to upload your route”.

Any help appreciated. I tried going through the ‘versions’ for each of my routes on MapHub but couldn’t figure out how to reduce them to just one.

An update on this. So, if I download a MapHub GPX file from my site it:

Opens two versions in the free Komoot (see image above)

Opens one version in the free Routes (see image below)

Won’t open any versions in the paid-for OS app (see image below)

Any help appreciated. A lot of people depend on these GPX files for the walks and I would like to fix this problem.



More info on this…

If I import a route from my GPS tracker into MapHub, create a map, then save it and export the GPX file there is no problem.

The file downloads as one version on Komoot and works in the OS app. All good.

So the problem seems to be when I create a route on the MapHub website then export the GPX file. That is when I get duplicate versions that won’t work on the OS app.


Hi David,

I’ve just double checked and on the walk you linked there is no “duplicate version” or anything similar. It’s just a pure, single GPX track. Try it on for example.

Also, what do you mean by the “paid for OS app”? Is this a 3rd application you are using?

Thanks for checking Zsolt.

Regarding your question about the OS app, people who use the free walks on Hertfordshire Walker save the GPX files (which I create on MapHub) on any mobile devices in order to follow the walks on their phones. The most popular app they use is Komoot, and all the files work on that app, but some use the paid-for OS subscription app, which seems to have problems reading some of the files.


I’ve just checked the GPX file from the linked map. It loads perfectly in every mobile app I could try. I might look into Komoot but it does sound like a bug in their app, as every other app I found is good.