Google Drive Picture Hosting Help


(Kat Glancy) #1

Hi! I’m hosting my pictures in a public folder on my Google drive. I can see the pictures when I put the coding in, but they’re not really showing up. Anyone know what I’m doing wrong here?


(Zsolt Ero) #2

Hi Kat,

Probably the problem is that Google doesn’t allow you to do so. Just use any other picture hosting, for example https://kek.gg/.

Also, the direct image uploading will be integrated into MapHub very soon!


(Nico Vadøy) #3

I got it to work using google drive:

So, go to your file in drive, right click and get the link of your picture.
Note that it will say google.com/OPEN?.… replace open with uc like in the above link.
insert your link into the map and done.


(Zsolt Ero) #4

Hi, it’s nice to know it works using Google Drive! Just make sure that you test it from a different browser or from Incognito Mode / Private Browsing session, to be sure that everyone can see the images as well!


(Kat Glancy) #5

Hi, Nico. It shows the image is broken for me. Did you move the picture since posting? I haven’t been able to get to my computer until today.


(Nico Vadøy) #6

Hi Kat,

no, I just posted an example.
I have replaced it now with a real picture:
Like this:

and here the code: ![](https://drive.google.com/uc?id=1_8jYiJun2hSTsqxl6OclJnLp_8fqFA8g)

Note the uc? part, this is what I have changed.


(Kat Glancy) #7

Hi Nico,

The image you posted is still showing up as broken :frowning:


(Nico Vadøy) #8

That is strange. In the Forum it shows now broken for me as well. it did show it correctly before.
When I check my Map the logo is still shown correctly.

See here.


(Kat Glancy) #9

Have you checked in incognito mode or in another browser were the cookies aren’t saving your image? That was happening to me as well, I could see it until I checked on my phone. I realized the cookies were on and loading the image.


(Nico Vadøy) #10

good news, bad news.
It worked fine on my PC with Chrome (normal and incognito) + Internet explorer.

It did not work on chrome on my phone (iOS + Chrome). There I just got a little box where the picture should be. :frowning:


(Kat Glancy) #11

I get that box on IE, too :frowning:


(Nico Vadøy) #12

OK, this is getting funny.
Can you try to go to my Map: https://maphub.net/nicovadoy/bvb_worldmap
go to Norway and click on the yellow Icon. Do you see the logo in there?

I tried now with Safari on mobile and that worked fine as well.
I have found there was an option to set a folder and or file in google drive to “public for the whole web”. But changing this did not actually have an effect it seems.

here is how:
If you want anyone on the internet to search for, find, and open your file, you can publicly share a file.

  • Click Get shareable link.
  • Next to “Anyone with the link,” click the Down arrow Down Arrow.
  • Click More and then On - Public on the web.
  • Click Save.
  • Choose the level of access you want people to have. Learn more about how others can view, comment, or edit files.
  • Click Done.

(Kat Glancy) #13

That’s how I have it set up already


(Nico Vadøy) #14

yes, that seems to be alright. and still not working for you?
can you send me the link of your map?


(Kat Glancy) #15

I stopped adding images, but there are still images on the downtown condos (ie. Tyndall at Robertson Hill, The Independent, Fifth & West, 1306 West)


(Nico Vadøy) #16

thanks, nice map.
I have checked the locations you mentioned, but cannot see any pictures either :frowning:

Have you tried one of the other suggested image hosting sites? at least to test if it works for you?
If not, I am running out of ideas…


(Zsolt Ero) #17

Hi,

Google doesn’t allow hot linking images, as far as I know. Maybe it works for a time but then it stops working.

I recommend picking an image sharing provider from this article for example, which will allow including images.